Thursday, 3 January 2013

My experience of Networking our SAMIL River 5200TL-D Solar Inverter

 
The SAMIL has a variety of network connectivity methods and my objective was to get it connected to my LAN using WiFi

At the time of writing this blog entry, there are entries on many different forums describing the various difficulties experienced in attempting to get the WiFi communications working.

To date I have been partially successful so will document my findings here in the hope that they may help others attempting the same process.
Inverter model: As per title 
PC OS: XP SP3
Software: Samil Power Co - SolarPower Browser V2.9.2.6
Network:
* Type: 10/100 Ethernet with two WiFi routers 
* LAN subnet address is 192.168.0.x
* Billion Router BiPAC 7800N serving DHCP for LAN and WiFi using WPA/WPA2-PSK Mixed 802.11 b/g/n on Channel 8 with ESSID visible and shared key
* D-Link Router DIR-615 WiFi using Auto (WPA or WPA2) TKIP and AES Mixed 802.11 b/g/n on Channel 8 with SSID visible and shared key
  1. Connected SAMIL to Billion router via RJ45 Ethernet cable (referred to as netting twine in the SAMIL manual!) 
  2. On SAMIL Esc to Home menu
  3. Down arrow to Settings then OK
  4. Right arrow and Down arrow to Network then OK
  5. Up arrow for "1" then Right arrow for next password digit - repeat for all digits then OKi.e. 1 1 1 1 1 1 OK
  6. For Ethernet Interface I initially tried Auto-IP/DHCP but could not get a connection
    Note1: I could find no trace of a DHCP request in the router Syslog for any unidentifiable MAC address
    Note2: The MAC address being used by the SAMIL LAN interface was NOT that shown in the SAMIL System Info screen but does belong to the same address-space owner (see below)
    Interesting side-note: The System Info screen shows a MAC address of 24:08:28:02:03:00 which when searched on sites like  hwaddress.com are unknown
    IF HOWEVER you invert the MAC address as I've seen some commercial Router interface cards do, you get 00:03:02:etc which co-incidentally returns the address-space owner as Charles Industries which further research shows as "www.charlesindustries.com ... Heavy-duty use inverters for sensitive electronics"
    Further side-note: The MAC address eventually displayed (via ARP -a) once the browser was connected and working over the LAN cable, was another unknown address ...
    18-08-1C-02-03-00, yet once again, if you invert that MAC you again get 00:03:02:etc which obviously resolves to Charles Industries again.
  7. Went back in and set to Manual IP, setting the device to 192.168.0.40 along with all other other IP values such as subnet, gateway, DNS etc
  8. This time when I saved the settings the SAMIL appeared to reboot its software, after which I could effortlessly load and connect to the device using the SolarPower browser
  9. Doing an ARP - a on the PC with the browser running I ascertained the cabled MAC address as noted in (6) above.
  10. Next I selected the inverter name under the expanded "Inverters" list in the LH frame of the SolarPower Browser
  11. Selected the "Parameters" tab in the main frame of the browser
  12. Under Module Flag WIFI, I entered the SSID of my primary WiFi router (the D-Link DIR-615) and the Password (Shared Key) for that router SSID  then selected SAVE
  13. By the time I walked to the inverter, it appeared to be rebooting the software ... which it proceeded to do again and again and again (I thought I had stuffed it and it had gone into perpetual reboot!) then it stopped and returned to stable state.
  14. As soon as I got to the inverter I had unplugged the LAN cable but after the reboots stopped and I returned to my PC, I could not connect to the device.
    The hard-coded IP address (192.168.0.40) was no longer reachable and I could find no trace of a DHCP request to issue an alternate IP.
  15. Back to the SAMIL and changed the IP setting to Auto-IP/DHCP. The SAMIL rebooted (once) but still no WiFi Connectivity
  16. Back to the SAMIL and changed the IP setting to WIFI, leaving the Ethernet settings untouched (Auto-IP/DHCP). The WIFI setting showed the correct SSID. The SAMIL the went into it's multiple reboot scenario again!
  17. When the rebooting finished, still no WiFi connectivity so reconnected the LAN cable but could not get to the device
  18. Reset the SAMIL to the Manual IP settings (incidentally, settings were still retained even after setting to use DHCP). SAMIL rebooted. I could again get to the device on the .40 IP address
  19. I then entered the ESSID of the Billion router and it's passkey and upon SAVE the SAMIL again did it's multi-reboot thing!
  20. Disconnecting the LAN cable and reloading the browser I now had WIFI connectivity BUT ...
    I could find no trace of a new MAC address in the tables or logs of EITHER of the routers!!

    I got called away from my testing.
  21. Returning several hours later there was no longer any WiFi connectivity.!!
  22. To cut a long story short ... going through the process of connecting the LAN cable, assigning a static IP, connecting the browser and re-saving the SSID which forces the SAMIL reboot process, seems to establish WIFI connectivity SOMETIMES but then always for only a short time.
    Unproven at this stage, but I suspect the WIFI connection is dropped when a WIFI group key handshake occurs!

In Summary

It looks like the SAMIL will only connect the WIFI following it's reboot cycle after updating the WIFI settings. Any subsequent disruption of the WIFI communication (pairwise group handshaking etc) seems to break the connection and it does not re-establish.

It also appears that the wired LAN connection will ONLY work with all IP details specified and will NOT acquire a DHCP address despite DHCP being alive and well for other devices on the network.

If you have any comments or feedback please do add to my findings here.

Update to this post here

17 comments:

Col. Sanders said...

I have received no communication back from my australia@samilpower.com enquiry sent on the 3rd Jan 2013 - Colin

Anonymous said...

Well presented testing, I have a newly installed River 5200TL-D Solar Inverter, Wireless Lan connection gets lost will not stay on, i have tried two netgear modem/routers.

Col. Sanders said...

Thanks for the comment Anonymous.
Have you seen my two subsequent posts about the SolarPower Browser software?

Tony A said...
This comment has been removed by the author.
Tony A said...

Gidday Col

Im interested in your output results for your solar array
Im running the SolarRiver 4500TL-D
with Qcell panels.

What's your array specs?

P.S:Ive also had significant problems with my wifi connection but it seems to be working fine now (early days!)

Col. Sanders said...

Hi Tony
Thanks for the comment
I'd be equally interested in hearing what you did to get the WiFi working!!!
I'm in the throws of an update post on what has happened so far, because the unit failed completely and would not stay on-line so is to be replaced by Samil.
As to the full specs, I'll need to look up the panel details, but initially, its a 6Kw bank made up of 2 arrays, 1x 11 & 1x 13 panels.
The BEST days I've managed to record so far were 39.37kw and 38.69kw with a daily average for Jan of 28.01kw and so far this month (for the days the system has worked) an average of 27.41kw.
The WORST uninterrupted days were during our Qld storm when we only made 2.26kw & 7.8kw.
Watch for another post soon and I'll put my generation spreadsheet up there.
Regards Col.

Tony A said...

Gidday Col

I had my system since early Jan and I am only now getting a reliable signal through the WiFi.
A family friend who does IT Infrastructure couldn't get it to work and I believe it was dumb luck on my part that its even working now.

I rang Samil in Sydney and spoke to a technician, he basically helped me set it up by reciting the manuals WiFi setup instructions to me. The only thing I was doing wrong was I needed to be hard wired to the Inverter (LAN cable to my wireless router)to setup the WiFi.

So after programming the Inverter with my SSID and password I hung up the phone went wireless... couldn't get a signal (ARRRGGH!!).3 Days later I got signal for 2 Days and after restarting my computer nothing!

2 Weeks later I think I've solved the problem after setting up the WiFi I needed to program the Inverter to use the Manual IP setting(192.168.000.002), I had the power company doing some line maintenance in my area so I reset the Inverter by turning it off and on and used the manual IP settings as the SSID was still programmed into the Inverter.

I have noticed a couple of things that may be of interest. The DHCP Client List in my router is showing the host name for the inverter as being GainSpan019999 & I think the MAC Address has changed since the last time I was getting signal.

Its been 4 Days of constant signal now and after typing this I am going to test it all by turning off my router and PC. Im hoping that in 5 minutes I wont have a large bald patch and a hand full of hair.

Tony

Col. Sanders said...
This comment has been removed by the author.
Col. Sanders said...

I have posted details of our system
in this post

Anonymous said...

Please note that a firmware upgrade was issued by Samil early last year which fixed the wifi stability problem and an issue with the production graph on the Home screen.

This problem only applied to models from 2012 and early 2013. late models had the upgraded firmware direct from the factory.

Contact Samil Service on 1300 134 793 to get sent the upgrade.

Michael King
Technical Support
Mark Group Australia

Tony A said...

I gave up on the concept of WIFI communication with the inverter in august last year and ran a LAN cable under the house to the bloody thing.

As far as constant communication goes being hard wired to the unit is better but I still have days of data that just disappear from my computer (3 Days this month and the Solar Power Browser as far as detailed info and really needs to be reworked out of the 1960's)and I regularly troll the samil website for updates and apply them as soon as they are released in the delusional belief that one day I will get what I paid for a solar inverter that is a good generator of power (I have my doubts) and communicates reliable data to me.

Adrian Tindall said...

My Samile 5200TL-D was stable running firm version 1.3 in the inverter. For some stilly reason I upgraded to version 1.7 and I can no longer get data on the web portal, over wifi or RJ45 Solar browser still connects fine. Tech support was great. When you look on the inverter screen you should see v1.7 in 3 different systems (within the once screen. In my case the top 2 showed 1.7 but the bottom showed v1.3

They have suggested reload firmware and if still an issue than the internal SDI card is faulty and needs replacement then another reload of v1.7 I'll keep you posted how it goes

I live at Gosford NSW. Sunny day yields 40 -43 kW in summer. The system is over sized with Tygo panels. I have 7.6Kw worth of panels which has the VOC values at 534.4v per MPPT.

EkDor said...

Just setting ours up (using SPB 3.2.3.0) I wasn't able to get ours to autoIP/DHCP until after I fully populated the manual setting, as you mention. But After I had a connection to the browser I was able to immediately switch it to the auto. So far so good. Not been long enough to know if it will stick. But it is running connected to it's own bridged router since I don' have enough ethernet lead to reach any of the others. I want to use its own WiFI since it supposedly can.

My issue is with setting up the Wi-Fi. When I enter my "correct" SSID and PW and click save, I get a popup dialogue asking for a password. I assume this is the inverter password. The same as used to edit the settings on the inverter? It fails no matter what I put in with an error like this "Password error,can't write data", yes the missing space is yet more confidence boosting! I tried to change the password on the inverter to see if that would help. No change. Router password not it either.

Why they can't allow us to just enter this information directly via the inverter buttons is beyond me. A simple scrolling keyboard similar to the password one would do for such limited requirement applications like this.

Adrian T said...

Following up from my January 2015 post. No luck with sorting the upgrade issues. The inverter was replaced by Samil power.

Darren Frost said...

Hi, I had my Inverter fitted today, I have managed (with your help) to see the IP I've assigned it on my router BUT I can't connect to it from my browser NORE can I see my data on the app or on the SamilPortal?! How do you see your data?

Col. Sanders said...

Hi Darren
Back to basics then ...
I'll assume your inverter is LAN cabled to to the router and your PC is LAN cabled to that same router.

If you can see the inverter IP address at the router, can you PING it from the PC you will run the software on?

Two paths will come from your answer:
If we follow the path of assuming you CAN PING the inverter from the PC, the first thing I would consider is whether you have firewall software running on your PC, as this will likely be blocking the traffic.
e.g. Windows firewall, AVG, Zone Alarm, Comodo, Norton Internet Security, AVG, etc

Post back your actual config incl how things are connected (i.e. Wifi, cabled, etc.) and how you have configured your inverter and PC IP addresses (i.e. DHCP or fixed IP, subnet masks, etc.)
Also whether you can PING the inverter from the PC
Regards Col. Sanders

Romy Ferrer said...

Hello buddies,
I too am having a really big problem on the orientation of the Samil Solar River 5200TL remote monitoring. I was wondering if what i did crimp on my UTP Cable is the right color and pin designation on the RJ45. I am so much confused because on the manual which i have, the picture shows an RJ11 while our units have an RJ45 ports on RS485. honestly guys, i am so lost and confused. Can anybody show and teach me how i can inter-connect our 5 inverter units and monitor the power output via our router to the computer? What color and pin designation will i crimp in order for me to monitor the units using the Samil Browser.
Thank you.