Sunday, 10 March 2013

March 10 2013 update to: 

My experience of Networking to our
SAMIL River 5200TL-D Solar Inverter

A lot has transpired since my last post in this series and as I am getting rather a large number of hits on the information in this blog, I thought I should at-least offer a bit of an update.

Since the last post, through multiple communications between Samil, myself and my installer, we determined that something had gone wrong with the firmware in the first Inverter. With little fuss and bother apart from me having to take two periods off work to be in attendance, the Inverter was replaced with another unit.

On the day that the inverter was scheduled to be swapped out, Samil R&D came back with 

The feedback from R&D about your inverter is that your inverters firmware is blank for some reasons.
Please update your firmware again on the inverter followed by the instruction.
The first one had version 1.02 firmware, this latest one has version 1.10 which appears to be the same as what was in the .rar file Samil supplied to do the update ... so I never attempted the update.

So the new inverter is in and it seems to be recording generation stats reliably and not doing anything silly like rebooting multiple times etc.

Sadly however ... communication between the Samil and any recording PC system is still unusable.
It still connects only intermittently and will not remain connected for any length of time.
The new one even reached the point that I could not talk to it at all ... until I did as I describe in some detail below.

The upside is that I have figured out how to get it to use DHCP and how to get it to connect using WiFi ... albeit only for short periods!

So follows is my latest communication back to Samil with all the detail of the steps I took in my diagnosis.
If anyone has questions or comments, I'd love to hear them.

P.S. The significance of the "When Daytime" below, is because of this feedback from the R&D team ...
At least, the disappear of master and slave DSP is because of the night time.
During the night, the software version will disappear due to the lack of dc power.
... which sadly isn't entirely correct as the version details can be present or disappear at any time

Hello Again {name}
So I did as I indicated {in the last communication} ... I set up a dedicated LAN with one PC , one WiFi Router and the Samil

In summary:
I got it to work again, but once-again, only for a short while

I did manage to get it to use both DHCP and WiFi for that short period and thus was able to capture the WiFi MAC address ... which was helpful.
I could not get it to use DHCP through a secondary WiFi router despite other devices doing so successfully
      (from a network engineers perspective I’m struggling to see how that is possible, unless the Samil imposes some sort of hop-count limit on its discovery packets, as everything is on the same subnet [192.168.0.] )

Details (perhaps for the R&D team?)

When Daytime
Instantaneous Samil producing between 2 and 4kW
System Info displays ALL THREE version details
History seems intact with no anomalies in recorded values compared to those I’ve recorded manually each day
Event list is showing a series of 22 - PV2 Input current high entries at times when I suspect we had peak sunlight each day
(This is something we never saw with the first inverter!)
·         Took spare windows PC and configured network interface as
·         Disabled the PC firewall software
·         Took spare D-Link WiFi Router and reset to factory default
·         Connected PC to router via LAN cable
·         Logged in and configured router to be same IP as the gateway router I was using on my live home network ...
Note: DHCP on this standalone router enabled with a scope of 100~199
·         Router restarted and I was able to connect to it on the new address
·         Confirmed Samil network settings ... SettingsNetwork (password) – EthernetManual-IP ...
·         OKOK back to main screen
·         Set PING /t running on new PC .... Destination unreachable
·         Unplugged Samil LAN cable from household LAN and plugged into standalone Router
·         PING on new PC immediately registered the connection of the SAMIL
·         From a USB I installed the SolarPower BrowserV2.9.2.6 software on the new PC
·         Started the SolarPower Browser and configured it to use the network
SettingsUse Network – Defaults
·         Clicked Connectno sign of any Inverter
·         Waited a while still no sign
·         Decided to go into Samil network settings and set everything back to 0
Set  to use DHCP
·         Samil rebooted and came back online
·         It had appeared in the standalone router DHCP client list this time, as
·         Started the SolarPower Browser and Inverter appeared shortly thereafter ... which is typical after a Samil reboot
o   Out of interest I went and checked the home LAN DHCP scope  it is even wider at 30~254
·         Configured standalone WiFi router wireless
·         WCN Off
·         SSID TtamedSamil
·         Channel AutoSelect
·         Secuity Off
·         Reset the Samil WiFi configuration to TtamedSamil no password
o   Received configuration success message
·         WiFi client address appeared in router ... YAY !
(Now at-least I can get the MAC address of the Samil WiFi interface so I can see if it’s appearing anywhere on the network!)
For reference the WiFi interface shows up as
00:1D:C9:01:99:99 with a Client Host Name of GainSpan019999
·         I could still PING and the SolarPower Browser was still working
·         Could also ping the address allocated to the WiFi connection
·         Unloaded and reloaded SolarPower Browser and it worked fine via WiFi
·         Now I started systematically going through making the standalone WiFi settings the same as those on the Home LAN
·         First up ... the security
o   Tried to update Samil WiFi config with intended SSID passkey but received message that I could not update wifi settings
o   Turned off wireless on Router and reconnected Samil LAN cable
o   Unloaded and reloaded SolarPower Browser and it again worked fine via the LAN cable
o   Updated Samil WiFi config with same SSID but added strong passkey ... “Set parameter is successed!”
o   Set WiFi security to WPA/WPA2 (enhanced) as PSK with the same strong passkey as entered in the Samil
o   Several minutes later a wireless connection reappeared as the same address as previously
o   Disconnected Samil LAN cable and restarted SolarPower Browser – took several minutes bit did eventually reconnect
·         Next the Mode
o   I noticed the Samil had connected as 802.11B
o   The downstairs router was set to accept only G or N so that could have been an issue, however
o   The upstairs router which was the main one I had been trying to connect to and it was accepting all three modes, B, G and N 
·         Putting the Mode aside for a minute the next thing is that we have a lot of Wireless interference in our home so we had determined the most stable WiFi channel for our network devices was Channel 8, thus our routers are set to use channel 8, so I set the new standalone one to Channel 8 (instead of Auto)
o   It took it a while but eventually it figured it out and the SolarPower Browser reconnected
·         Next was to enable 802.11B on the downstairs gateway router as that is the one which issues DHCP for our home network and try WiFi connecting the Samil to that so it would be almost identical to the standalone configuration I had working.
·         Reconfigure main router to accept B,G and N
·         Reconnect to Samil via LAN cable on standalone network and reconfigure the WiFi SSID and Passkey to that of the Home LAN gateway (DHCP enabled) router
... “Set parameter is successed!”
·         Immediately the SolarPower Browser on the standalone PC connected vi LAN cable, stopped working and already the Samil had appeared in the DHCP lease table of the Home Network Router ... SO I believe THE ISSUE WAS at-least two-fold:
o   For some reason it could not acquire a DHCP address across the upstairs WiFi router from the Downstairs (DHCP server) router
o   The fact that 802.11B was not enabled on the downstairs router was stopping the Samil from connecting directly to it.
·         So now the Samil is connected to the home LAN via WiFi, but I still cannot get the copy of SolarPower Browser installed on the Home PC to connect to the Samil!
·         Turn off the firewall software on that Home LAN PC (as I’ve done many time before) and reload the SolarPower Browser ... Still no Samil!
·         Reconfigure standalone PC with an available 192.168.0 address and move it to the Home LAN - SolarPower Browser works!
·         Re-enabled the Firewall software on what was the standalone PC – everything still working fine!
·         Lunch time ... an hour later I come back to the PC ... No SolarPower Browser
·         I check the DHCP table on the router ... No Samil
·         PING the last known WiFi Address ... Request Timed Out
·         I moved The PC and Samil (LAN cable) back to the standalone Router
o   The PC immediately acquired a DHCP address but there was no sign of the Samil attempting to renew it’s address L
So I’m sorry to report that we are pretty much at square-one in terms of getting reliable comms with the Samil
I’m sure a Samil reboot would restore the cabled LAN connection ... for a while ...

No comments: